Degraded Call Quality
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Sep 22, 2017 - 08:29 MST
Identified
A subset of Nextiva customers in the Florida area are currently experiencing degraded call quality. Our engineers are working to reach a resolution as quickly as possible. Thank you for your patience.
Posted Sep 21, 2017 - 08:18 MST
Investigating
A subset of Nextiva customers are currently experiencing degraded call quality. Our engineers are aware of the issue and are working to resolve it as soon as possible. Thank you for your patience.
Posted Sep 21, 2017 - 07:02 MST