Nextiva Service CRM
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Aug 06, 2018 - 11:55 MST
Investigating
We are currently experiencing issues with Nextiva Service CRM, which is preventing both customers and our internal team from accessing or properly using the tool. Our engineers are aware of the issue and are working to resolve it as quickly as possible. Thank you for your patience.
Posted Aug 06, 2018 - 11:22 MST