Nextiva vFAX Portal Issue
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Sep 15, 2018 - 13:08 MST
Identified
Nextiva vFAX customers are currently unable to access vfax.nextiva.com. Our team is aware of the issue and our engineers are working to resolve this as quickly as possible. In the meantime you can use the URL https://vfax.nextiva.com on Google Chrome or Firefox (with Flash enabled), or on Internet Explorer.
Posted Sep 14, 2018 - 20:48 MST