Nextiva App on iOS
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Apr 19, 2018 - 23:17 MST
Investigating
A subset of Nextiva customers who use the Nextiva App on iOS are currently experiencing difficulty receiving inbound calls. Outbound calls are fully functional. Our engineers are working to resolve this as quickly as possible.
Posted Apr 19, 2018 - 18:33 MST