Nextiva Voice: Voicemails
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Nov 11, 2018 - 06:12 MST
Update
A subset of Nextiva customers have had incoming voicemails not delivered properly. Our engineers are still looking into this and continue working to resolve it as soon as possible. Thank you for your patience.
Posted Oct 30, 2018 - 10:23 MST
Investigating
A subset of Nextiva customers have had incoming voicemails not delivered properly. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted Oct 27, 2018 - 12:19 MST