Nextiva Headquarters
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 10:42 MST
Investigating
Nextiva is currently experiencing a connectivity issue at our headquarters. Our engineers are aware of the issue and working with our Internet Service Providers to resolve this as soon as possible. This is not impacting our customers’ service. In the meantime, please email us at support@nextiva.com and we will respond as soon as possible.
Posted Nov 17, 2020 - 10:04 MST