Nextiva Voice Inbound Calls
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 9 days ago. Oct 05, 2019 - 22:45 MST
Identified
A subset of Nextiva Voice Customers have some phone numbers delivering error messages when called. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 10 days ago. Oct 05, 2019 - 12:51 MST
Update
We are continuing to investigate this issue.
Posted 10 days ago. Oct 05, 2019 - 12:40 MST
Update
We are continuing to investigate this issue.
Posted 10 days ago. Oct 05, 2019 - 12:35 MST
Investigating
A subset of Nextiva Voice customers are experiencing inbound call failures. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 10 days ago. Oct 05, 2019 - 12:33 MST
This incident affected: Nextiva Office.