Nextiva App and Portal Login
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted May 11, 2022 - 14:15 MST
Monitoring
A fix has been implemented and we are monitoring to ensure no further login issues.
Posted May 11, 2022 - 13:46 MST
Investigating
A subset of Nextiva customers are experiencing issues logging into the Nextiva App and the Nextiva Voice Portal. Our engineers are aware of this and are currently investigating.
Posted May 11, 2022 - 13:28 MST
This incident affected: Nextiva App.