Nextiva Voice Inbound Call Failure
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Mar 22, 2019 - 13:52 MST
Investigating
A subset of Nextiva Voice customers have callers receiving a busy tone or an error message when dialing in. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted Mar 22, 2019 - 09:38 MST
This incident affected: Nextiva Office.