Nextiva vFAX Portal Performance
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 12, 2019 - 13:22 MST
Investigating
A subset of Nextiva vFAX customers are experiencing the vFAX portal not loading, or loading with a significant delay. This does not affect customers sending faxes via fax machines using a fax bridge, or faxes sent via email. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted about 1 month ago. Aug 12, 2019 - 10:21 MST
This incident affected: Nextiva vFAX.