Nextiva Support Number
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Nov 30, 2021 - 12:37 MST
Investigating
We’re currently experiencing issues with some of our support phone numbers. If you need phone-based technical support, you can call (800) 799-0600 and press 2 for support. You can also always reach the Nextiva Support team by visiting nextiva.com/support to chat live with a team member or to submit a ticket, or by sending an email to support@nextiva.com. Thank you for your patience.
Posted Nov 30, 2021 - 11:38 MST