Nextiva Support + Hurricane Florence
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Sep 14, 2018 - 19:29 MST
Monitoring
As Hurricane Florence approaches the East Coast, a number of our customers are in the path of the hurricane and may experience service issues from the severe weather. As a result, wait times when calling our customer support team may be longer than usual. Please feel free to email support@nextiva.com for assistance.
Posted Sep 13, 2018 - 13:22 MST