Nextiva Analytics
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 27 days ago. Aug 26, 2019 - 14:34 MST
Investigating
A subset of Nextiva customers are currently unable to access Nextiva Analytics. However, data is still being recorded. Our engineers are aware of the issue and are working to resolve it as quickly as possible. Thank you for your patience.
Posted 27 days ago. Aug 26, 2019 - 12:25 MST
This incident affected: Nextiva Analytics.