Nextiva Inbound vFax
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 16:04 MST
Update
We are continuing to investigate this issue.
Posted Jul 02, 2020 - 13:04 MST
Investigating
A subset of our vFAX customers are currently experiencing issues with receiving faxes. All Nextiva vFAX users are able to send faxes. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted Jul 02, 2020 - 10:03 MST
This incident affected: Nextiva vFAX.