Nextiva App Logins on Windows
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Apr 17, 2021 - 11:27 MST
Identified
The issue has been identified and our teams are working to resolve as soon as possible.
Posted Apr 17, 2021 - 08:55 MST
Investigating
A subset of Nextiva customers are currently unable to log in to the Nextiva App on Windows. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted Apr 17, 2021 - 07:38 MST
This incident affected: Nextiva App.