Nextiva Voice
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Apr 25, 2018 - 14:13 MST
Investigating
A subset of Nextiva customers are currently experiencing audio quality issues. Our engineers are aware of the issue and are working to resolve it as soon as possible. Thank you for your patience.
Posted Apr 25, 2018 - 10:08 MST