Nextiva App Logins
Incident Report for Nextiva
Resolved
This incident has been resolved. Anyone still experiencing a login issue should reset their password by selecting the password reset option from the login page.
Posted Jul 21, 2021 - 07:38 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2021 - 07:10 MST
Investigating
A subset of Nextiva customers are currently experiencing issues logging into various Nextiva applications. Our engineers are aware of this and are working toward resolution. Thank you for your patience.
Posted Jul 21, 2021 - 06:23 MST
This incident affected: Nextiva App.