Nextiva Voice Portal
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Jan 02, 2019 - 12:04 MST
Investigating
A subset of Nextiva Voice customers cannot access the Nextiva Voice Portal. Our engineers are aware of this and are working to resolve it as soon as possible. The ability to place and receive calls have not been affected. Thank you for your patience.
Posted Jan 02, 2019 - 11:41 MST