Nextiva HQ
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Oct 17, 2017 - 15:30 MST
Investigating
Nextiva is currently experiencing an Internet outage at our headquarters. Our engineers are aware of the issue and are working to resolve it as soon as possible. This will not impact our customers' service. We apologize for the inconvenience and thank you for your patience.
Posted Oct 17, 2017 - 11:47 MST