Nextiva Voice: Voicemails
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Nov 19, 2018 - 08:16 MST
Investigating
A subset of Nextiva Voice customers cannot listen to voicemails, or configure new users' voicemail. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted Nov 19, 2018 - 07:38 MST