Nextiva CRM Unavailable
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 5 days ago. Oct 10, 2019 - 09:08 MST
Update
A subset of Nextiva CRM customers are currently getting errors when attempting to access the NextOS platform, leaving them unable to access the CRM. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 5 days ago. Oct 10, 2019 - 08:45 MST
Investigating
We are currently investigating this issue.
Posted 5 days ago. Oct 10, 2019 - 08:43 MST
This incident affected: Nextiva CRM.