Hurricane Dorian
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 11 days ago. Sep 11, 2019 - 14:10 MST
Investigating
As Hurricane Dorian approaches the southeastern U.S., a number of Nextiva customers are in the path of the storm and may experience service interruptions from the severe weather. As a result, wait times when calling our customer support team may be longer than usual. Please feel free to email support@nextiva.com for assistance. If you need to forward your numbers in preparation for the hurricane, please complete this form: nextiva.com/forwarding.html
Posted 23 days ago. Aug 30, 2019 - 11:03 MST