Nextiva Voice Portal
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 5 months ago. May 03, 2019 - 10:52 MST
Update
A subset of Nextiva Voice customers are getting errors or extreme slowness when trying to sign in to their Nextiva Voice Portal. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 5 months ago. May 03, 2019 - 10:16 MST
Investigating
A subset of Nextiva Voice administrators are getting a blank screen after signing in to their Nextiva Voice Portal. This does not impact customer abilities to make or receive calls. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 5 months ago. May 03, 2019 - 08:47 MST
This incident affected: Nextiva Office.