Nextiva HQ
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Jun 11, 2018 - 10:06 MST
Identified
Nextiva is currently experiencing an Internet outage at our headquarters. Our engineers are aware of the issue and working to resolve this as soon as possible. This should not impact our customers’ service. We apologize for the inconvenience and thank you for your patience.
Posted Jun 11, 2018 - 09:02 MST