Nextiva Voice Phones
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Nov 20, 2018 - 15:58 MST
Monitoring
A subset of Nextiva customers’ phones have disconnected, and as a result, they currently cannot make or receive calls. Our engineers have implemented a fix and we are monitoring until all devices successfully reconnect. Thank you for your patience.
Posted Nov 20, 2018 - 14:29 MST