Nextiva Voice Legacy Portal
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 19, 2019 - 09:27 MST
Investigating
A subset of Nextiva Voice customers on our legacy platform are receiving error messages when attempting password resets, editing administrators, or editing numbers on Auto Attendants. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 2 months ago. Jul 19, 2019 - 08:31 MST