Intermittent Nextiva CRM
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 4 months ago. May 29, 2019 - 16:28 MST
Monitoring
Nextiva’s engineers have restored consistent functionality to the Nextiva CRM. Due to the intermittent nature of the issue, we are continuing to monitor the service to ensure stability for our customers.
Posted 4 months ago. May 29, 2019 - 09:12 MST
Investigating
A subset of Nextiva CRM customers are intermittently getting blank pages, or endlessly spinning loading screens, when accessing their CRM Agent View. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 4 months ago. May 28, 2019 - 16:08 MST
This incident affected: Nextiva CRM.