Nextiva Voice Inbound Call Failure
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 05, 2019 - 13:41 MST
Investigating
A subset of Nextiva Voice customers are not receiving calls to some of their phone numbers. Calls made to those phone numbers have a busy tone or an "all circuits are busy" message. Our engineers are aware of this and are working to resolve it as soon as possible. This does not affect the ability to place calls. Thank you for your patience.
Posted 4 months ago. Jun 05, 2019 - 10:15 MST
This incident affected: Nextiva Office.