Nextiva Contact Center Login Issues

Incident Report for Nextiva

Resolved

This incident has been resolved, and logins are working as intended.
Posted Jan 28, 2026 - 18:25 MST

Identified

The issue has been identified, and engineers are developing a plan to implement the fix.

Next update will be within 30 minutes.
Posted Jan 28, 2026 - 18:06 MST

Investigating

A subset of users are experiencing issues logging into their Nextiva Contact Centers. Engineers are engaged and investigating the issue.
Posted Jan 28, 2026 - 17:35 MST
This incident affected: Nextiva Contact Center.