Nextiva Contact Center Client Issues

Incident Report for Nextiva

Resolved

A fix has been implemented and impact has been mitigated. The incident is resolved.
Posted Jan 30, 2026 - 09:39 MST

Investigating

A subset of users are experiencing issues navigating the application, making and receiving calls, and handling work items via ACD. Engineers are engaged and looking at the issue.
Posted Jan 30, 2026 - 09:24 MST
This incident affected: Nextiva Contact Center.