Nextiva vFax Inbound Issues

Incident Report for Nextiva

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 12:04 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2026 - 10:20 MST

Investigating

We are currently investigating an issue affecting customers receiving inbound faxes. Engineers are engaged and looking into the issue. The next update will be provided within the next 30 minutes.
Posted Mar 31, 2026 - 09:52 MST
This incident affected: Nextiva vFAX.