Nextiva Voice Portal
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Apr 15, 2019 - 08:24 MST
Investigating
A subset of Nextiva Voice customers are experiencing lag or timeouts while using the Nextiva Voice Portal. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted Apr 15, 2019 - 08:15 MST