Nextiva Voice Portal
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 24 days ago. Sep 21, 2019 - 01:30 MST
Investigating
A subset of Nextiva Voice customers cannot log in to the Nextiva Voice Portal. Our engineers are aware of this and are working to resolve it as soon as possible.
Posted 24 days ago. Sep 21, 2019 - 00:51 MST
This incident affected: Nextiva Office.