This incident has been resolved and inbound calls are working as intended for all customers.
Posted Sep 11, 2026 - 07:05 MST
Identified
The issue has been identified and a fix is currently being implemented. We are starting to see resolution for some of the affected users as the change continues to be applied. We will continue to update through full completion of remediation efforts.
Posted Sep 11, 2026 - 06:55 MST
Investigating
A subset of our customers are experiencing issues receiving inbound calls within Nextiva Contact Center. Engineers are engaged and investigating the issue.