Nextiva Voice Inbound Calls
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 10 days ago. Sep 12, 2019 - 14:50 MST
Investigating
A subset of Nextiva Voice customers are experiencing inbound call failures to some phone numbers with callers experiencing a busy tone or an error message stating “all circuits are busy”. Our engineers are aware of this and are working to resolve it as soon as possible. This does not affect the ability to place calls. Thank you for your patience.
Posted 10 days ago. Sep 12, 2019 - 11:37 MST
This incident affected: Nextiva Office.