Nextiva Portal Login
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 11 days ago. Oct 04, 2019 - 01:16 MST
Investigating
A subset of Nextiva customers are currently unable to log in to the customer portal. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 11 days ago. Oct 03, 2019 - 23:34 MST
This incident affected: Nextiva Office.