Nextiva Call Center login failures

Incident Report for Nextiva

Resolved

This incident has been resolved
Posted Sep 18, 2026 - 07:41 MST

Identified

A subset of users are experiencing issues logging into their Nextiva call center account via username. Engineers are engaged and currently working on resolution. Users can login via email as a workaround until this issue is resolved
Posted Sep 18, 2026 - 07:34 MST
This incident affected: Nextiva Call Center.