Nextiva Contact Center Login Issues

Incident Report for Nextiva

Resolved

A fix has been implemented, and users should no longer experience issues loading dashboards, resetting passwords, or logging in via Salesforce CTI. If you continue to experience issues, please clear your browser cache and cookies before trying again. The incident is resolved at this time.
Posted Jul 01, 2026 - 06:10 MST

Investigating

Nextiva Contact Center users are experiencing issues logging in through Salesforce CTI, resetting passwords, and loading dashboards within their account. Engineers are engaged and investigating the issue.
Posted Jul 01, 2026 - 05:44 MST
This incident affected: Nextiva Contact Center.