Nextiva Voice Outbound Call Failures
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 08:18 MST
Investigating
A subset of Nextiva Voice customers are experiencing outbound call failures to some phone numbers, mostly international phone numbers. Our engineers are aware of this and are working to resolve it as soon as possible. This does not affect the ability to receive calls. Thank you for your patience.
Posted 2 months ago. Jul 11, 2019 - 07:12 MST
This incident affected: Nextiva Office.