Nextiva Voice Inbound Calls
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 5 days ago. Oct 10, 2019 - 11:55 MST
Investigating
A subset of Nextiva Voice customers are having some inbound calls fail to connect to their service. Our engineers are aware of this and are working to resolve it as soon as possible. This does not affect the ability to place calls. Thank you for your patience.
Posted 5 days ago. Oct 10, 2019 - 11:10 MST
This incident affected: Nextiva Office.