Nextiva CRM Data Export
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 6 days ago. Oct 09, 2019 - 19:54 MST
Investigating
A subset of Nextiva CRM customers cannot currently export data. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 6 days ago. Oct 09, 2019 - 16:45 MST
This incident affected: Nextiva CRM.