Nextiva Support Number Issue
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted May 31, 2023 - 10:00 MST
Investigating
We are currently experiencing an issue with inbound calls to our Nextiva Support number. Please utilize https://www.nextiva.com/support/ to chat or log a ticket.
Posted May 31, 2023 - 08:55 MST
This incident affected: Nextiva Support.