Nextiva Analytics
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted Apr 27, 2018 - 13:14 MST
Update
Our engineers continue to monitor this issue and apply any improvements necessary to resolve it as quickly as possible. Thank you for your patience.
Posted Apr 25, 2018 - 20:14 MST
Identified
A subset of Nextiva customers are currently experiencing an issue when loading Nextiva Analytics. Our engineers are aware of the issue and are working to resolve it as soon as possible.
Posted Apr 23, 2018 - 11:55 MST