Nextiva Voice Phones
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 17 days ago. Sep 05, 2019 - 09:13 MST
Investigating
A subset of Nextiva Voice customers’ phones and softphones have disconnected from Nextiva’s network and are not reconnecting. Our engineers are aware of this and are working to resolve it as soon as possible. Thank you for your patience.
Posted 17 days ago. Sep 05, 2019 - 06:29 MST
This incident affected: Nextiva Office.