Nextiva Voice Portal
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 08:18 MST
Investigating
A subset of Nextiva Voice customers are receiving error messages when attempting to make changes to their users in the Nextiva Voice Portal using the Google Chrome browser. Our engineers are aware of this and are working to resolve it as soon as possible. In the meantime clearing your browser’s cache and cookies should resolve the issue on that browser.
Posted 2 months ago. Jul 11, 2019 - 07:30 MST
This incident affected: Nextiva Office.