Nextiva Voice Inbound Call Failure
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 11, 2019 - 11:16 MST
Investigating
A subset of Nextiva Voice customers are not receiving calls to some of their phone numbers. Our engineers are aware of this and are working to resolve it as soon as possible. This does not affect the ability to place calls. Thank you for your patience.
Posted 2 months ago. Jul 11, 2019 - 11:06 MST
This incident affected: Nextiva Office.