Phone De-registration
Incident Report for Nextiva
Resolved
This incident has been resolved.
Posted May 15, 2018 - 09:26 MST
Investigating
A subset of Nextiva customers are currently experiencing phone de-registration issues. Our engineers are working to resolve this as quickly as possible.
Posted May 15, 2018 - 07:17 MST